Remote Support Prerequisites

Hardware Requirements

TSplus Remote Support Client runs on both 32 and 64-bit editions of Windows computers.

TSplus Remote Support Server may only be installed on 64-bits editions of Windows computers.

OPERATING SYSTEM

TSplus Remote Support is compatible with the following OS:

  • Windows XP Professional or Windows XP Home.
  • Windows Vista  Premium, Professional, Corporate or Ultimate Edition
  • Windows 7  Professional, Corporate or Ultimate Edition
  • Windows 8 Professional/8.1
  • Windows 10
  • Windows 2008 Server or 2008 R2/SBS
  • Windows 2012 Server or 2012 R2
  • Windows 2016 Server
  • Windows 2019 Server
  • 32 and 64 bits are supported

Dependencies

TSplus Remote Support requires .NET Framework to be installed on the computer.

The minimum version supported is .NET Framework 4.5.2.

If the .NET Framework is not installed on the computer, TSplus Remote Support setup program will try to download and install it.